Forums

Topic: Can't make DS4 controller work on PC! (Yellow light)

Posts 1 to 1 of 1

rvartanyanov

Im trying for 2 days now to make the DS4 work properly on my PC, but seem to fail.
The controller is detected in windows but when I plug in the USB it starts giving off yellow light (supposed to be blue) which I think means it's charging? Anyhow, I installed DS4 Windows and the gamepad works fine, but I notice some functions like changing the light of the controller doesn't respond, vibration testing also doesn't work (big and small motor rumble on DS4 windows).

Tested the vibration with a third party software - it works as well as every single button on the controller. Everything works with Steam's Big Picture mode testing too (DS4 Windows off)

The ONLY thing that works IN games though is the touch pad and the touch pad press.

I get the feeling that something is wrong with the connection from DS4 Windows rumble and light changing options not responding + the yellow light, but it seems the controller itself works just fine.

What I've tried:
1-Holding the reset button on the back of the controller for up to 30 seconds.
2-Uninstalling detected controller devices from the Control Panel
3-Tired using it on a different computer(laptop this time) - exact same thing happens.
4-Installed and reinstalled DS4 Windows's driver several times.
5-Used older version (from 2016) of DS4 Windows - same thing.
6-Tried bluetooth pairing it - it detects it and seem to connect to the controller, but nothing works without the USB cable.

Edited on by antdickens

rvartanyanov

Top

  • Pages:
  • 1

Please login or sign up to reply to this topic